23 November 2019

Fix "Your device isn't compatible with this version" on Play Store

Leave a Comment
Sometimes when you are trying to install any app from Google Play Store on your phone, you will encounter an error message which says "Your device isn't compatible with this version". You will not see any Install button on the app page.

Fix your device isn't compatible with this version error in Play Store

This error usually occurs on high-end apps that require a special environment to work such as large RAM memory and storage space, particular Android version, screen resolution, etc. However, there are several other reasons that can cause this error on Google Play Store.

In this tutorial, we will show you various methods to fix the "your device isn't compatible with this version" error on your Android phone quickly.

Why this error occurs in Google Play Store


Let's first discuss the reasons that can cause the "your device isn't compatible with this version" error on Google Play Store -
  • There are great chances that your phone is running on the Android version which is currently not supported by the app you are trying to install.
  • Another reason could be that your device doesn't meet the hardware requirements of the apps. This can happen if your phone has low RAM memory and you are trying to install any big app or game such as PubG.
  • Some apps require specific screen resolution to work properly. If your Android phone doesn't support that screen resolution, then you may get this error message on Google Play Store.
  • It might be possible that there is some technical glitch in the Google Play Store app on your phone due to which it is showing this error message. This issue can be fixed easily.
  • Some apps are made to work on particular smartphones only. They will not work on other Android phones and you will get this error "device not compatible" while you try to install them from Google Play Store.

Fix "device isn't compatible" error


Below we have shared some methods that can help you to fix the "your device isn't compatible with this version" error on Google Play Store. -

"Your device isn't compatible with this version" error

1. Clear Google Play Store app cache and data


As we have already discussed, this error can be caused by some technical glitch in the Google Play Store app. You can simply fix that issue by clearing the app cache and app data of Google Play Store on your phone. Follow these steps -
  1. First, go to the Settings and open Apps (or Applications).
  2. A list of apps is displayed there. Find and open Google Play Store.
  3. In the usage section, click the Storage option.
  4. Now tap the "Clear cache" button. This will delete all cached data of the Google Play Store app.
    Clear Google Play Store app data and cache

  5. Next, tap the "Clear data" button and then click OK to confirm it. Please note that this option will delete all of the app's data including files, settings, accounts, databases, etc.
Now when you will open the Google Play Store app on your phone, you have to sign in to your Google account again. After that, just go to the app you are trying to install. If you are lucky, you wouldn't see any error this time.

Note: If there is an option to uninstall updates of Google Play Store in the app info, then you can also try that option afterward.

2. Clear Google Play Services app data and cache


Sometimes Google Play Services app can also cause the "your device isn't compatible with this version" error on your Android phone due to some technical issues. Again, this can be fixed by clearing the app's cached data. The steps are almost the same as we have shared above -
  1. First, go to Settings > Apps.
  2. Find the Google Play Services app.
  3. Click the Storage option under Usage.
  4. Now tap those "Clear data" and clear "Clear cache" buttons. That's it.
    Clear Google Play Services app data and cache

3. Install app using APK file


If the Google Play Store is still showing the same error message, then you can try out this workaround by installing the app directly using the app's APK file. You can download the APK file from the third-party app stores.

You can use APKMirror which is one of the most popular app stores for Android. APKMirror contains almost all apps that are available on the Google Play Store. Once you have download the APK file, just install it on your phone.

You will be asked to enable permission for installing apps from unknown sources. If you are facing any error while installing the app, then try to install some older versions. They may be compatible with your device. APKMirror also provides the facility to download any version of the app you want.

4. Update your phone's software


If your phone is running on Android version which is not supported by the app, then also you can get the "your device isn't compatible with this version" error on Google Play Store. In this case, we will recommend you to update your phone's software with the latest Android version. To check if any software update is available on your phone, simply go to Settings > Software update.

5. Change your phone's screen resolution


Last but not least, you can try to fix the "your device isn't compatible with this version" error by changing your phone's screen resolution. We have already posted a tutorial on how to change screen resolution on Android. Some smartphones have a built-in feature in their settings. On the other hand, you can also change the DPI (dots per inch) in developer options.

So these are various methods to fix the "your device isn't compatible with this version" error on Google Play Store while you are trying to install any app. Hope it would be informative and helpful. Let us know which method worked for you. If you got any questions, ask it in the comments right now.

Leave A Comment